php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79785 Assertion `(zend_gc_refcount(&(ht)->gc) == 1) || ((ht)->u.flags & (1<<6))' fail
Submitted: 2020-07-04 04:36 UTC Modified: 2020-07-07 13:34 UTC
From: changochen1 at gmail dot com Assigned:
Status: Duplicate Package: Scripting Engine problem
PHP Version: 8.0Git-2020-07-04 (Git) OS:
Private report: No CVE-ID: None
 [2020-07-04 04:36 UTC] changochen1 at gmail dot com
Description:
------------
LOG:
---
php: /home/yongheng/php_clean/Zend/zend_hash.c:731: zval *_zend_hash_add_or_update_i(HashTable *, zend_string *, zval *, uint32_t): Assertion `(zend_gc_refcount(&(ht)->gc) == 1) || ((ht)->u.flags & (1<<6))' failed.
---

Test script:
---------------
<?
try {
    define ( ob_start ( function () {
        global $a ;
        list ( $a ) = $b   ;
    }
    , 20 )  )  ;
}
catch ( Error ) {
    $a [ $c ] = 'x' ;
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-07-07 13:34 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2020-07-07 13:34 UTC] nikic@php.net
This has the same root cause as bug #79784.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 30 07:01:23 2020 UTC