php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79766 PECL no longer included in published docker build
Submitted: 2020-07-01 18:01 UTC Modified: 2020-07-01 18:03 UTC
From: eric at ericstern dot com Assigned:
Status: Not a bug Package: PECL (PECL)
PHP Version: 8.0.0alpha1 OS: docker/alpine linux
Private report: No CVE-ID: None
 [2020-07-01 18:01 UTC] eric at ericstern dot com
Description:
------------
This is presumably intentional and temporary, but PECL is not included in the published Docker image: `php:8.0.0alpha1-fpm-alpine` (it also appears to be missing in fpm-buster). For software that depends on pecl packages, this makes testing against the alpha builds difficult/impossible.

Test script:
---------------
$ docker run --rm -it php:8.0.0alpha1-fpm-alpine sh

/var/www/html # apk add $PHPIZE_DEPS && pecl install apcu && docker-php-ext-enable apcu


Alternatively, in a Dockerfile:

FROM php:8.0.0alpha1-fpm-alpine
RUN apk add --update \
  $PHPIZE_DEPS \
  && pecl install apcu \
  && docker-php-ext-enable apcu \
  && && rm -rf /var/cache/apk/*

Expected result:
----------------
Installation completes, or at least returns an error that the pecl packages haven't been updated for PHP 8 yet.

Actual result:
--------------
sh: pecl: not found

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-07-01 18:03 UTC] derick@php.net
-Status: Open +Status: Not a bug
 [2020-07-01 18:03 UTC] derick@php.net
We don't control these docker builds. They call them "official", but they're official *docker*, not official PHP.
 [2020-07-01 18:05 UTC] eric at ericstern dot com
Oh, no kidding. I'll try https://github.com/docker-library/php/issues instead. Thanks!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 04:01:25 2020 UTC