php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #79752 "LoadModule php_module" required, not php8_module
Submitted: 2020-06-28 10:11 UTC Modified: 2020-06-30 13:54 UTC
From: buschmann at nidsa dot net Assigned: nikic (profile)
Status: Closed Package: *Configuration Issues
PHP Version: 8.0.0alpha1 OS: Windows Server 2019 64bit
Private report: No CVE-ID: None
 [2020-06-28 10:11 UTC] buschmann at nidsa dot net
Description:
------------
When configuring PHP8 alpha1 for apache by loading php8apache2_4.dll I configured the config line as:

--------------v
LoadModule php8_module "N:\Apache\php8\php8apache2_4.dll"

according to the longtime praxis of using 

LoadModule php7_module "N:/Apache/php7/php7apache2_4.dll"

This failed to load the module.

Instead I had to guess to use 

LoadModule php_module "N:\Apache\php8\php8apache2_4.dll"

instead which worked.

This change should be documented in the incompatible changes section of the release notes and by a correct example in the chapter for installing under Windows / under apache.

Environment:
- Windows server 2019 64bit Standard in a VM under HyperV
- Apache 2.43 64bit from apachelounge
- php 8 alpha1 64bit thread safe from php.net QA download
- php loaded as a module with php_module




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-06-30 13:49 UTC] cmb@php.net
-Assigned To: +Assigned To: nikic
 [2020-06-30 13:49 UTC] cmb@php.net
Indeed, this has been changed[1].  @nikic, shouldn't this also be
mentioned in UPGRADING?

[1] <http://git.php.net/?p=php-src.git;a=commit;h=6e3600f41b95d97d11ef48f817e6389a4ee95091>
 [2020-06-30 13:54 UTC] nikic@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 14:01:31 2024 UTC