php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79550 Reloading the httpd service repeatedly causes a memory corruption error.
Submitted: 2020-05-01 07:33 UTC Modified: -
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: kitagawa at sraoss dot co dot jp Assigned:
Status: Open Package: Apache2 related
PHP Version: 7.3.17 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
46 - 39 = ?
Subscribe to this entry?

 
 [2020-05-01 07:33 UTC] kitagawa at sraoss dot co dot jp
Description:
------------
Hi,

I'm running Apache 2.4.41 on CentOS 6.4 server.

There was a problem (memory corruption),
when graceful reloading the httpd service many times.

The version of each app is as follows:
 - httpd-2.4.41
 - apr-1.5.2
 - apr-util-1.5.4
 - php-7.3.4

The following steps will cause the problem.

 # cat /opt/httpd/htdocs/index.php
 ------
 <?php
 phpinfo();
 ?>
 ------

 # /etc/init.d/httpd start
 Starting httpd:                                            [  OK  ]


Display phpinfo() in your browser and check that it is working.
 http://localhost/index.php


Now, when I run the following script, an error occurs (about 1023 times).

 # for i in $(seq 1030) ; do echo $i; /opt/httpd/bin/httpd -k graceful;  done

 # less /opt/httpd/log/error_log
 ・・・・
 [XXX XXX XX 16:05:23.261688 2020] [mpm_prefork:notice] [pid 2875] AH00171: Graceful restart requested, doing restart
 *** glibc detected *** /opt/httpd/bin/httpd: malloc(): memory corruption: 0x00000000021a4010 ***
 *** glibc detected *** /opt/httpd/bin/httpd: malloc(): memory corruption: 0x00000000021a4010 ***



This bug occurs when loading the libphp7.so module.
Different libphp7.so versions have the same result.
But that doesn't happen with the libphp5.so module.
It occurs on CentOS 7 as well as CentOS 6.

Thanks,
Regards.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-05-01 08:25 UTC] bugreports at gmail dot com
chck out which extensions are loaded, on Fedora for some time "imap.so" loaded had a similar result so that i switched to restart instead of reload on machins which need it
 [2020-05-07 02:10 UTC] kitagawa at sraoss dot co dot jp
Thank you for your comment.
Did a similar problem occur with "imap.so"?

Currently, we continue to provide services including restart, 
but we want to restart and operate as safely as possible.

Also, there are many servers that are graceful restart all over the world(including logrotate),
so I would like to ask for a fundamental response.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Oct 31 20:01:24 2020 UTC