php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79500 Duplicate function execution due to an HTML error
Submitted: 2020-04-20 12:15 UTC Modified: 2020-04-20 13:30 UTC
From: dev at vraq dot fr Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 7.4.5 OS: All
Private report: No CVE-ID: None
 [2020-04-20 12:15 UTC] dev at vraq dot fr
Description:
------------
(Sorry if my English isn't always correct, I'm still struggling with the language (and I'm using DeepL to help me))

Version of PHP where the bug was found: 7.4, 7.3, 7.2 (WAMP et Infomaniak)

For some reason, this bug occurs when there is an HTML tag containing an empty background-url style attribute :

<div style="background-image: url('');"></div>

This line generates, depending on the content of the defined function, a double execution of the function.

Test script:
---------------
I made a small demonstration of the bug in a few lines: https://test.vraq.fr/php_css_bug/

Expected result:
----------------
An entry must be present in the log file when the page is loaded.

Actual result:
--------------
Two entries were made in the file as if the function had been executed twice.

I have the same problem with a mail function. Conversely, if you put an ECHO in the function, it will be displayed only once.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-04-20 13:30 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2020-04-20 13:30 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The script IS being executed twice.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 18:05:46 2022 UTC