php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79493 REDIRECTTESTs ignore CONFLICTS
Submitted: 2020-04-19 14:29 UTC Modified: 2020-04-25 13:29 UTC
From: cmb@php.net Assigned: cmb (profile)
Status: Not a bug Package: Testing related
PHP Version: 7.4Git-2020-04-19 (Git) OS: *
Private report: No CVE-ID: None
 [2020-04-19 14:29 UTC] cmb@php.net
Description:
------------
run-test.php supports CONFLICTS files and sections so all tests
with the same conflict tag are always run sequentially to avoid
test case conflicts. However, REDIRECTTESTs are not aware of these
CONFLICTS, so, for instance, PDO tests using PDO_MYSQL may run in
parallel with mysqli tests, which can cause spurious test
failures.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-04-24 14:52 UTC] nikic@php.net
Are you sure about this? At the level where we process REDIRECTTEST, we should see the CONFLICTS and mark the test as conflicting. The test only gets broken down to the individual tests later (possibly even on a worker? Not sure on that.)
 [2020-04-25 13:29 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-04-25 13:29 UTC] cmb@php.net
Ah, you're right.  There is no such issue regarding the redirected
tests.  Sorry for the noise.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 08 05:01:23 2021 UTC