php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79430 Handling signed char on Big endian arch
Submitted: 2020-03-30 04:57 UTC Modified: 2020-03-30 11:31 UTC
From: vibhutisawant18 at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: EXIF related
PHP Version: master-Git-2020-03-30 (Git) OS: Ubuntu 16.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vibhutisawant18 at gmail dot com
New email:
PHP Version: OS:

 

 [2020-03-30 04:57 UTC] vibhutisawant18 at gmail dot com
Description:
------------
This bug is related to https://bugs.php.net/bug.php?id=79336.

char data type is signed(-128 to 127) by default on x86 arch whereas char is
unsigned(0 to 255) by default on s390x.
In function static float php_ifd_get_float(char *data) of
php-src/ext/exif/exif.c ,the 3rd byte (data[2]) is referring to -8(Hex:
fffffff8 ),where as its referred to 248 (Hex: f8) on s390x as char is treated as unsigned char.

could you please guide us on what could possibly help to tackle the above
scenario?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-03-30 11:31 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2020-03-30 11:31 UTC] cmb@php.net
Duplicate of bug #79336.
 [2020-03-30 11:31 UTC] cmb@php.net
Duplicate of bug #79336.
 [2020-05-15 07:20 UTC] vibhutisawant18 at gmail dot com
Can this issue be closed? as it got fixed in Bug 79336(https://bugs.php.net/bug.php?id=79336)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jan 21 19:01:27 2021 UTC