php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79428 ICU bg_BG Locale wrong currency format after v.57.1
Submitted: 2020-03-29 14:44 UTC Modified: 2020-03-29 15:15 UTC
From: bashev at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: I18N and L10N related
PHP Version: 7.3.16 OS: Linux
Private report: No CVE-ID: None
 [2020-03-29 14:44 UTC] bashev at gmail dot com
Description:
------------
All version of intl which using ICU > 57.1 are with wrong locale.

NumberFormatter returns 0.00 instead of '#,##0.00 ¤' which is correct one.

Test script:
---------------
$formatter = new \NumberFormatter('bg', \NumberFormatter::CURRENCY);
echo $formatter->getPattern();


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-03-29 15:15 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-03-29 15:15 UTC] cmb@php.net
This is obviously an upstream issue.  Please report that to the
ICU project[1].

[1] <http://site.icu-project.org/bugs>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Aug 08 21:01:26 2020 UTC