php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79397 Session Variable failed to pass for weird reason
Submitted: 2020-03-18 20:19 UTC Modified: 2020-03-19 03:39 UTC
From: generalp2 at aol dot com Assigned:
Status: Not a bug Package: Scripting Engine problem
PHP Version: 7.2.28 OS: Unix
Private report: No CVE-ID: None
 [2020-03-18 20:19 UTC] generalp2 at aol dot com
Description:
------------
See below

Test script:
---------------
Can anyone tell me why this code didn’t work:
  $vu=$_SESSION["valid_user"];
  $txt="PROBLEM: You may not proceed. You are not logged in.";
  if ($vu!="Yes") {php_alert($txt,"index.php");}

but this code did?
  $chk=$_SESSION["valid_user"];
  $txt="PROBLEM: You may not proceed. You are not logged in.";
  if ($chk!="Yes") {php_alert($txt,"index.php");}

The Session variable didn’t pass from another program in the first case but did in the second case.
Chuck Patton
Generalp2@aol.com



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-03-18 20:20 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2020-03-18 20:20 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2020-03-18 20:21 UTC] generalp2 at aol dot com
This is a bug!!!
 [2020-03-19 03:39 UTC] generalp2 at aol dot com
found it depended on whether another program ran first. Please ignore this report
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed May 12 02:01:23 2021 UTC