php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79381 Cannot not load extensions
Submitted: 2020-03-13 17:19 UTC Modified: 2020-03-13 17:20 UTC
From: raul dot pinto at graphity-consulting dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 7.4.3 OS: Windows 10 Pro
Private report: No CVE-ID: None
 [2020-03-13 17:19 UTC] raul dot pinto at graphity-consulting dot com
Description:
------------
PHP cannot load any extensions starting from PHP 7.4.0. I attached my php.ini. Error messages are found in php_error.log:

[13-Mar-2020 17:03:29 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'curl' (tried: d:\opt\wamp\bin\php\php7.4.0\ext\curl (Das angegebene Modul wurde nicht gefunden.), d:\opt\wamp\bin\php\php7.4.0\ext\php_curl.dll (Das angegebene Modul wurde nicht gefunden.)) in Unknown on line 0
[13-Mar-2020 17:03:30 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'curl' (tried: d:\opt\wamp\bin\php\php7.4.0\ext\curl (Das angegebene Modul wurde nicht gefunden.), d:\opt\wamp\bin\php\php7.4.0\ext\php_curl.dll (Das angegebene Modul wurde nicht gefunden.)) in Unknown on line 0


Test script:
---------------
Link to php.ini: https://www.graphity-consulting.com/tests/php-error.ini

Expected result:
----------------
Extensions are loaded

Actual result:
--------------
Extensions are not loaded

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-03-13 17:20 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Package: Dynamic loading +Package: cURL related
 [2020-03-13 17:20 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

https://www.php.net/manual/en/curl.installation.php
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 14:01:44 2020 UTC