php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79320 The "empty" function is not recognized as a callable.
Submitted: 2020-02-29 02:08 UTC Modified: 2020-02-29 03:05 UTC
From: ilya at bakhlin dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: Irrelevant OS: Windows, GNU/Linux, macOS
Private report: No CVE-ID: None
 [2020-02-29 02:08 UTC] ilya at bakhlin dot com
Description:
------------
<?php

is_callable("empty") // false;

Test script:
---------------
<?php

if (is_callable("empty")) {
    echo "It is a callable function."
} else {
    echo "It is not a callable function."
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-02-29 03:05 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2020-02-29 03:05 UTC] requinix@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

https://www.php.net/manual/en/function.empty.php

empty is a language construct, not a function.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 18:03:36 2022 UTC