php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #7930 list() constructor reference assignment
Submitted: 2000-11-22 12:00 UTC Modified: 2016-12-29 01:28 UTC
Votes:6
Avg. Score:3.2 ± 1.7
Reproduced:1 of 2 (50.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: nathan at cjhunter dot com Assigned:
Status: Duplicate Package: Scripting Engine problem
PHP Version: * OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nathan at cjhunter dot com
New email:
PHP Version: OS:

 

 [2000-11-22 12:00 UTC] nathan at cjhunter dot com
I request that the list() constructor be able to assign variable references from arrays. Like such..

$a = array("string1", "string2");

list($b, $c) =& $a;

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-29 18:52 UTC] nathan at cjhunter dot com
This feature request has been in the bug database for more than a year now.  Will this request ever be implemented? If so, great! Please assign it to a developer. If not, then say why and close this request.

Bug #6768 is a duplicate of thsi bug

 [2010-11-19 00:16 UTC] jani@php.net
-Summary: List() constructor reference assignment +Summary: list() constructor reference assignment -Package: Feature/Change Request +Package: Scripting Engine problem
 [2013-03-04 11:22 UTC] dlsniper@php.net
-Operating System: Linux 2.2 +Operating System: * -PHP Version: 4.0.2 +PHP Version: *
 [2016-12-29 01:28 UTC] ajf@php.net
-Status: Open +Status: Duplicate
 [2016-12-29 01:28 UTC] ajf@php.net
Duplicate of bug #6768.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC