php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #6768 list() construct reference assignment
Submitted: 2000-09-15 05:28 UTC Modified: 2002-01-06 12:19 UTC
From: nathan at cjhunter dot com Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0.2 OS: Linux 2.2.14
Private report: No CVE-ID:
 [2000-09-15 05:28 UTC] nathan at cjhunter dot com
I'm requesting that that the list() construct which is an assignment construct, assign variable references. Like such..

<?
$array = array(1, 2, 3);

list($a, $b, &$c) = $array;

?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-06 12:19 UTC] jan@php.net
dupe of #7930 and marking it "dublicate"
 
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Sat May 30 14:01:46 2015 UTC