php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79281 PDO_OCI doesnt connect to the DB
Submitted: 2020-02-19 09:23 UTC Modified: 2020-02-19 23:11 UTC
From: mkimani09 at gmail dot com Assigned: sixd (profile)
Status: Not a bug Package: PDO OCI
PHP Version: 7.4.2 OS: Linux & Windows
Private report: No CVE-ID: None
 [2020-02-19 09:23 UTC] mkimani09 at gmail dot com
Description:
------------
I have simple index.php where i'm just trying to connect PHP 7.4 to oracle 12c,
But it doesn't connect. On phpinfo i can see the driver loaded.

Switching to php 7.3, that connection to 12c works.

I believe its a bug on 7.4 PDO_OCI


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-02-19 12:23 UTC] cmb@php.net
-Assigned To: +Assigned To: sixd
 [2020-02-19 23:11 UTC] sixd@php.net
-Status: Assigned +Status: Not a bug
 [2020-02-19 23:11 UTC] sixd@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The bug db is not the best place to discuss installation troubleshooting.  

Please post in a help forum, e.g. https://community.oracle.com/community/groundbreakers/database/developer-tools/php  
You will need to give much more information about the installation such as operating system, how you install Oracle client libraries, what errors you get etc.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Apr 06 21:01:23 2020 UTC