php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7922 Loss of Connection and crash on odbc_execute
Submitted: 2000-11-22 07:30 UTC Modified: 2001-05-07 21:37 UTC
From: kalowsky@php.net Assigned:
Status: Closed Package: ODBC related
PHP Version: 4.0 Latest CVS (22/11/2000) OS: FreeBSD 4.1.1-Stable
Private report: No CVE-ID:
 [2000-11-22 07:30 UTC] kalowsky@php.net
PHP latest CVS, built with-solid enabled.

the statement:
"SELECT * FROM SYS_TABLE"

put through odbc_prepare, and next to odbc_execute 
will cause PHP to lose the database handle, and in 
some cases crash the PHP (not yet locally 
reproducable).

Apparently (notes from the Solid mailing list) the 
SYS_TABLE has two columns of type  'LONG 
WVARCHAR' which require being handled via a 
passthrough mechanism (eg. BLOB). 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-22 11:28 UTC] kalowsky@php.net
Further information:

When using a PHP v3.0.17 system and Apache, 1.3.9 this bug does not appear.  When using a PHP v3.0.17 and Apache 1.3.14 this bug appears.  

This bug seems to be prevailent in all forms of PHP4.

 The LONG VARCHAR works, the LONG VARBINARY also works (That is, it doesn't crash PHP, so I guess it works). Just don't try to ask for data from the SYS_* tables. Very strange.
 [2001-05-07 21:37 UTC] kalowsky@php.net
this looks like it was actually fixed.  
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 10:02:06 2014 UTC