php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79129 PHP.net Website Problem
Submitted: 2020-01-16 14:32 UTC Modified: 2020-01-16 15:05 UTC
From: tellusyourproblem11 at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: cURL related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tellusyourproblem11 at gmail dot com
New email:
PHP Version: OS:

 

 [2020-01-16 14:32 UTC] tellusyourproblem11 at gmail dot com
Description:
------------
I found out that PHP curl request isnt aynchronous. it blocks my entire page loads until the server has resolved it. please @Official_PHP - I would like this to be improve on upcoming PHP binary release. thanks. i'm available for followup regarding this through my email. 

Test script:
---------------
I found out that PHP curl request isnt aynchronous. it blocks my entire page loads until the server has resolved it. please @Official_PHP - I would like this to be improve on upcoming PHP binary release. thanks. i'm available for followup regarding this through my email. 

Expected result:
----------------
I found out that PHP curl request isnt aynchronous. it blocks my entire page loads until the server has resolved it. please @Official_PHP - I would like this to be improve on upcoming PHP binary release. thanks. i'm available for followup regarding this through my email. 

Actual result:
--------------
I found out that PHP curl request isnt aynchronous. it blocks my entire page loads until the server has resolved it. please @Official_PHP - I would like this to be improve on upcoming PHP binary release. thanks. i'm available for followup regarding this through my email. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-01-16 15:05 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-01-16 15:05 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed May 12 11:01:25 2021 UTC