php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79127 Giving wrong mod value for
Submitted: 2020-01-16 12:44 UTC Modified: 2020-01-16 13:26 UTC
From: dattatray dot gavade at encureit dot com Assigned: cmb (profile)
Status: Not a bug Package: *Math Functions
PHP Version: Irrelevant OS: Windows 7 64 bit
Private report: No CVE-ID: None
 [2020-01-16 12:44 UTC] dattatray dot gavade at encureit dot com
Description:
------------
$amount = 40.12;

$amount *= 100;
$val = ($amount % 100);
echo $val;

This is showing mod as 11 instead of 12

Test script:
---------------
$amount = 40.12;

$amount *= 100;
$val = ($amount % 100);
echo $val; // showing 11 instead of 12


Expected result:
----------------
12

Actual result:
--------------
11

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-01-16 13:26 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-01-16 13:26 UTC] cmb@php.net
Floating point values have a limited precision. Hence a value might
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jan 23 15:01:23 2021 UTC