php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79124 Failed to init .Net runtime
Submitted: 2020-01-15 18:17 UTC Modified: 2020-01-16 08:13 UTC
From: v-altruo at microsoft dot com Assigned: cmb (profile)
Status: Duplicate Package: Testing related
PHP Version: 7.3.14RC1 OS: Windows Server 2016
Private report: No CVE-ID: None
 [2020-01-15 18:17 UTC] v-altruo at microsoft dot com
Description:
------------
Test fails for x64 builds (did not have x86 machine to test this) regardless of nts/ts and opcache on/off. It also fails for php-7.4.2RC1.

Failed Test Location: ext\com_dotnet\tests\bug77177.phpt


Same output as: https://bugs.php.net/bug.php?id=79123

Expected result:
----------------
Exception: Serialization of 'com' is not allowed
Exception: Serialization of 'dotnet' is not allowed
Exception: Serialization of 'variant' is not allowed
Exception: Unserialization of 'com' is not allowed
Exception: Unserialization of 'dotnet' is not allowed
Exception: Unserialization of 'variant' is not allowed

Warning: Erroneous data format for unserializing 'com' in %s on line %d

Notice: unserialize(): Error at offset 13 of 14 bytes in %s on line %d
bool(false)

Warning: Erroneous data format for unserializing 'dotnet' in %s on line %d

Notice: unserialize(): Error at offset 16 of 17 bytes in %s on line %d
bool(false)

Warning: Erroneous data format for unserializing 'variant' in %s on line %d

Notice: unserialize(): Error at offset 17 of 18 bytes in %s on line %d
bool(false)
===DONE===

Actual result:
--------------
Fatal error: Uncaught com_exception: Failed to init .Net runtime [CoCreateInstance] Class not registered
 in C:\..\php-test-pack-7.3.14RC1\ext\com_dotnet\tests\bug77177.php:3
Stack trace:
#0 C:\..\php-test-pack-7.3.14RC1\ext\com_dotnet\tests\bug77177.php(3): dotnet->dotnet('mscorlib', 'System.Collecti...')
#1 {main}
  thrown in C:\..\php-test-pack-7.3.14RC1\ext\com_dotnet\tests\bug77177.php on line 3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-01-16 08:13 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2020-01-16 08:13 UTC] cmb@php.net
This looks like a duplicate of bug #79123.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 29 09:01:28 2020 UTC