php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #79036 PIXEL_INTEGER constant undefined
Submitted: 2019-12-26 18:04 UTC Modified: 2019-12-29 12:17 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: gajowy at agzeta dot pl Assigned: cmb (profile)
Status: Closed Package: imagick (PECL)
PHP Version: 7.3.13 OS: Windows 10
Private report: No CVE-ID: None
 [2019-12-26 18:04 UTC] gajowy at agzeta dot pl
Description:
------------
Error appear when trying to use Imagick PIXEL_INTEGER constant.
Tested with:
PHP 7.3.13 (cli) (built: Dec 17 2019 13:16:21) ( NTS MSVC15 (Visual C++ 2017) x64 )
Imagick:
1799
ImageMagick 7.0.7-11 Q16 x64 2017-11-23 http://www.imagemagick.org

However it DOES work with:
PHP 7.1.33 (cli) (built: Oct 23 2019 09:22:42) ( NTS MSVC14 (Visual C++ 2015) x64 )
Imagick:
1683
ImageMagick 6.9.3-7 Q16 x64 2016-03-27 http://www.imagemagick.org

Test script:
---------------
$var = imagick::PIXEL_INTEGER;

Expected result:
----------------
Constant is defined.

Actual result:
--------------
PHP Fatal error:  Uncaught Error: Undefined class constant 'PIXEL_INTEGER' in...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-12-26 21:12 UTC] geekcom@php.net
-Assigned To: +Assigned To: geekcom
 [2019-12-26 21:12 UTC] geekcom@php.net
Tested in Ubuntu, i'll test in Windows 10 as reported.
 [2019-12-26 21:35 UTC] geekcom@php.net
Same error on Uuntu 18.04
 [2019-12-26 21:44 UTC] geekcom@php.net
-Assigned To: geekcom +Assigned To:
 [2019-12-27 09:34 UTC] cmb@php.net
-Status: Open +Status: Verified -Type: Bug +Type: Documentation Problem
 [2019-12-27 09:34 UTC] cmb@php.net
`PIXEL_INTEGER` is only defined for ImageMagick < 7[1].  Changing
to documentation issue.

[1] <https://github.com/Imagick/imagick/blob/060c34ac7e7600ca8443059cc6104f80e8c7ef13/imagick_helpers.c#L1391>
 [2019-12-29 12:16 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=348726
Log: Fix #79036: PIXEL_INTEGER constant undefined
 [2019-12-29 12:17 UTC] cmb@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: cmb
 [2019-12-29 12:17 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2019-12-29 12:20 UTC] salathe@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=e3abc61d616d84773b1471184fe6a96b7409c850
Log: Fix #79036: PIXEL_INTEGER constant undefined
 [2019-12-30 09:37 UTC] mumumu@php.net
Automatic comment from SVN on behalf of mumumu
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=348733
Log: Fix #79036: PIXEL_INTEGER constant undefined

Bug: https://bugs.php.net/79036 (Verified) PIXEL_INTEGER constant undefined
 [2020-02-07 06:04 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=0aab1793571fd404526f7f7e7838443f136d5ff3
Log: Fix #79036: PIXEL_INTEGER constant undefined
 [2020-12-30 11:59 UTC] nikic@php.net
Automatic comment on behalf of mumumu
Revision: http://git.php.net/?p=doc/ja.git;a=commit;h=f8053a0882e536322fef0212a027996648664919
Log: Fix #79036: PIXEL_INTEGER constant undefined
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Apr 20 11:01:23 2021 UTC