php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #79016 7.4.0 Release notes refers to "sqlite_stmt_readonly" which is not documented
Submitted: 2019-12-22 01:33 UTC Modified: 2019-12-22 02:17 UTC
From: silverwoodchuck47 at yahoo dot com Assigned:
Status: Not a bug Package: PDO SQLite
PHP Version: 7.4.1 OS: Win7-32
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: silverwoodchuck47 at yahoo dot com
New email:
PHP Version: OS:

 

 [2019-12-22 01:33 UTC] silverwoodchuck47 at yahoo dot com
Description:
------------
https://www.php.net/ChangeLog-7.php#7.4.0 has a section:

PDO_SQLite:

   * Implemented sqlite_stmt_readonly in PDO_SQLite.
   * Raised requirements to SQLite 3.5.0.
   * Fixed bug #78192 (SegFault when reuse statement after schema has changed).
   * Fixed bug #78348 (Remove -lrt from pdo_sqlite.so).
 
Bullet point 1 refers to "sqlite_stmt_readonly" which isn't documented anywhere in the help anywhere (that I can find).


Expected result:
----------------
That "sqlite_stmt_readonly" is documented somewhere.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-12-22 02:17 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-12-22 02:17 UTC] requinix@php.net
The name comes from the pull request which implemented it:

PR #2760 Implement sqlite_stmt_readonly in PDO
https://github.com/php/php-src/pull/2760

The actual implementation is the PDO::SQLITE_ATTR_READONLY_STATEMENT constant, as seen in the migration guide:

https://www.php.net/manual/en/migration74.new-features.php#migration74.new-features.pdo_sqlite
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 23:05:54 2022 UTC