php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78968 xdebug.remote_handler missing in html interface since xdebug 2.9.0
Submitted: 2019-12-16 11:59 UTC Modified: 2020-01-20 17:10 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: m dot opitz at qmul dot ac dot uk Assigned: derick (profile)
Status: Not a bug Package: Xdebug (PECL)
PHP Version: Irrelevant OS: Any
Private report: No CVE-ID: None
 [2019-12-16 11:59 UTC] m dot opitz at qmul dot ac dot uk
Description:
------------
With the update to Xdebug v.2.9.0 the web interface is missing the xdebug.remote_handler attribute (it is still there in the CLI) - and hence the debugging will not work.

There was a bug fix (bug #1720) that reported the removal of a "superfluous debug.remote_handler setting" - which seems to be not that superfluous at all..?!


Expected result:
----------------
Please return xdebug.remote_handler to the web interface.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-12-16 22:16 UTC] cmb@php.net
-Assigned To: +Assigned To: derick
 [2019-12-16 22:16 UTC] cmb@php.net
Please file Xdebug related bugs at <https://bugs.xdebug.org/>.
 [2020-01-20 17:10 UTC] derick@php.net
-Status: Assigned +Status: Not a bug
 [2020-01-20 17:10 UTC] derick@php.net
Xdebug does no longer need this setting, as it could only ever have one value. Xdebug also does not have a web interface, so I am not sure what you are referring to?

Just setting xdebug.remote_handler=dbgp in php.ini should still work, but will just have no effect as it hasn't done in the last 15 years.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 22 17:01:25 2020 UTC