php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78892 php-fpm: 7.4.0 chown() the socket Operation not permitted
Submitted: 2019-11-30 13:31 UTC Modified: 2019-11-30 13:38 UTC
From: ilya at ilya dot pp dot ua Assigned: cmb (profile)
Status: Duplicate Package: *Configuration Issues
PHP Version: 7.4.0 OS: openSUSE Tumbleweed
Private report: No CVE-ID: None
 [2019-11-30 13:31 UTC] ilya at ilya dot pp dot ua
Description:
------------
After upgrade to 7.4.0

listen = /run/php-fpm.sock
listen.owner = nginx
listen.group = nginx
listen.mode = 0600

ERROR: [pool php] failed to chown() the socket '/run/php-fpm.sock': Operation not permitted (1)

work only

listen = /run/php-fpm.sock
;listen.owner = nginx
;listen.group = nginx
listen.mode = 0666

Why it happens?
ArchLinux has the same problem.
https://bugs.archlinux.org/task/64683

Test script:
---------------
php-fpm:

listen = /run/php-fpm.sock
listen.owner = nginx
listen.group = nginx
listen.mode = 0600

Expected result:
----------------
Started The PHP FastCGI Process Manager

Actual result:
--------------
Starting The PHP FastCGI Process Manager...
ERROR: [pool php] failed to chown() the socket '/run/php-fpm.sock': Operation not permitted (1)
ERROR: FPM initialization failed
Main process exited, code=exited, status=78/CONFIG
php-fpm.service: Failed with result 'exit-code'.
Failed to start The PHP FastCGI Process Manager.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-30 13:38 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2019-11-30 13:38 UTC] cmb@php.net
Duplicate of bug #78889.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Dec 12 17:01:24 2019 UTC