php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78886 Non-strict comparison '@foo' == 0 resolves to true
Submitted: 2019-11-29 12:58 UTC Modified: 2019-11-29 13:02 UTC
From: frederik at sauerpower dot dk Assigned:
Status: Not a bug Package: Strings related
PHP Version: 7.3.12 OS: macOS Mojave 10.14.6
Private report: No CVE-ID: None
 [2019-11-29 12:58 UTC] frederik at sauerpower dot dk
Description:
------------
Any string starting with @, like '@foo', compared to 0 (zero) resolves to true.

Test script:
---------------
var_dump('@foo' == 0);
var_dump('@foo' === 0);

Expected result:
----------------
false
false

Actual result:
--------------
true
false

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-29 13:02 UTC] peehaa@php.net
-Status: Open +Status: Not a bug
 [2019-11-29 13:02 UTC] peehaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

https://www.php.net/manual/en/types.comparisons.php
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Mar 28 21:01:22 2020 UTC