php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78879 Serious bug again: SSL not working
Submitted: 2019-11-28 15:18 UTC Modified: 2019-11-29 02:22 UTC
From: gilperon at gmail dot com Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 7.2.25 OS: any
Private report: No CVE-ID: None
 [2019-11-28 15:18 UTC] gilperon at gmail dot com
Description:
------------
Run de code below. It just tries do connect to a local database and after that it tries to request a URL content. In the case below if I use https://www.sitepor500.com.br it does not work however if I use http://www.sitepor500.com.br (without SSL) it works. You can try with any URL, the problem relies on whether you are using SSL or not using SSL.

<?php

$conn = mysqli_connect("localhost","root","your_password");

$curl = curl_init();

$opts = array();

$opts[CURLOPT_URL] = "https://www.sitepor500.com.br";

curl_setopt_array($curl,$opts);

echo curl_exec($curl);

?>

Test script:
---------------
<?php

$conn = mysqli_connect("localhost","root","your_password");

$curl = curl_init();

$opts = array();

$opts[CURLOPT_URL] = "https://www.sitepor500.com.br";

curl_setopt_array($curl,$opts);

echo curl_exec($curl);

?>

Expected result:
----------------
I should be able to see the content of the request using CURL

Actual result:
--------------
Nothing is returned.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-28 15:25 UTC] peehaa@php.net
-Status: Open +Status: Duplicate
 [2019-11-28 15:25 UTC] peehaa@php.net
Serious duplicate of https://bugs.php.net/bug.php?id=78845 ?
 [2019-11-28 17:57 UTC] gilperon at gmail dot com
Yeah, serious duplicate of a serious bug that was not seriously fixed on version .24 and now seriously affects who use the latest seriously "unstable" version.
 [2019-11-28 23:10 UTC] peehaa@php.net
Seriously please don't seriously duplicate serious bug reports like this.

It makes it harder for us to keep track of serious and non-serious bug reports.

It's seriously sufficient to seriously notify on the serious original bug report (as you seriously did).

Again: the moment serious information gets spread out over multiple serious bug reports it just seriously gets hard to keep track off.

Seriously please do not seriously submit the same serious bug more than once. An existing serious bug report already seriously describes this very problem. Even if you seriously feel that your serious issue is somewhat different, the serious resolution is seriously likely to be the same.

Seriously thank you for your serious interest in serious PHP.

Thank you sinseriously
 [2019-11-29 00:02 UTC] wtf at wtf dot com
seriously why don't you fix it instead spread nonsense? 
similar stuff was reported *years* ago
https://bugs.php.net/bug.php?id=76714
 [2019-11-29 02:22 UTC] gilperon at gmail dot com
I seriously regret duplicating serious bug reports. But I sinceraly believed no one was gonna try to seriously fix/replicate the original serious bug report I made cause the status never changed and there was no one seriously assigned to it. 

If maybe, only maybe, the status changed or someone was assigned to it, I would probably stop duplicating the serious bug report.

I am worried cause someone pointed a very serious similar bug from LAST YEAR, and for some reason it was not seriously fixed.

This serious bug never happened to me, this is the first time and happened in the .24 version and in the .25 version! Seriously, how serious you think this serious bug can be seriously solved? Cause if there is no intention in solving it, I will migrate my PHP version to .20 and does not allow it to update anymore.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Dec 12 17:01:24 2019 UTC