php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78837 `--with-openssl=[DIR]` does not use [DIR]
Submitted: 2019-11-19 14:43 UTC Modified: 2019-11-19 16:08 UTC
From: pete at pragmatika dot net Assigned: cmb (profile)
Status: Not a bug Package: OpenSSL related
PHP Version: 7.4.0RC6 OS: Ubuntu 18.04 LTS
Private report: No CVE-ID: None
 [2019-11-19 14:43 UTC] pete at pragmatika dot net
Description:
------------
PHP 7.4.0RC6 does not appear to respect `--with-openssl=[DIR]` at compile time.

I run an Ubuntu server with PHP 7.2.24, PHP 7.3.11 and PHP 7.4.0RC6, primarily alongside Nginx via PHP-FPM. I compile PHP from source, and I bake in the latest OpenSSL (1.1.1d at the time of writing) among other things.

PHP 7.2 and 7.3 respects `--with-openssl=[DIR]` at compile time, but PHP 7.4,0RC6 does not. PHP 7.4.0RC6 uses the system-native version (1.1.1 at the time of writing).

Test script:
---------------
PHP 7.2 compile flags (working as expected):

https://gist.github.com/petecooper/3bcf1da07f54abdca285491e3b27330f

PHP 7.3 compile flags (working as expected):

https://gist.github.com/petecooper/17e7a19d0c9fd8c0442cce1e96e2d113

PHP 7.4.0RC6 compile flags (reverts to system-native OpenSSL):

https://gist.github.com/petecooper/7a0356402028f32073d17d1949191790

Headline details from `php -i` on PHP 7.2, PHP 7.3 and PHP 7.4.0RC6:

https://gist.github.com/petecooper/a115319bf010cedfe8e4b0128ac95212

OpenSSL details from `php -i` on PHP 7.2, PHP 7.3 and PHP 7.4.0RC6:

https://gist.github.com/petecooper/cb655cdae51884f8ebf74a679f79376d

Expected result:
----------------
I expect `--with-openssl=[DIR]` to respect the known-good OpenSSL library at the [DIR] location.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-19 15:30 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-11-19 15:30 UTC] cmb@php.net
As of PHP 7.4.0, the configuration of OpenSSL relies on
pkg-config, and the --with-openssl option no longer supports a
DIR.  See ./configure --help for further details.
 [2019-11-19 16:08 UTC] pete at pragmatika dot net
Thank you, cmb -- I appreciate the clarification.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Nov 29 08:05:54 2022 UTC