php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #78832 Support for avif format
Submitted: 2019-11-18 18:00 UTC Modified: 2019-11-18 18:04 UTC
From: vincent dot enjalbert at gmail dot com Assigned:
Status: Not a bug Package: GD related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2019-11-18 18:00 UTC] vincent dot enjalbert at gmail dot com
Description:
------------
I know the support is still almost inexistant.... Just supported in Windows10 since May, and no browser supports it atm, as far as I know. (There is however a polyfill : https://github.com/Kagami/avif.js)
But the AVIF format was born earlier this year, and support will probably arrive soon everywhere (AOM initiative, from google, mozilla, apple, etc...)
The promise of this format is big, and it should - finally - be a real replacement for our current outdated formats (jpg, ..).

avif spec : https://aomediacodec.github.io/av1-avif/
libavif : https://github.com/AOMediaCodec/libavif


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-18 18:04 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-11-18 18:04 UTC] requinix@php.net
GD is actually a separate project from PHP.
https://libgd.github.io/
 [2021-03-06 22:21 UTC] apostnikov at gmail dot com
PHP has bundled libgd so it could use update to https://github.com/libgd/libgd/releases/tag/gd-2.3.2 which added AVIF & HEIF support
 [2021-03-08 23:21 UTC] morss at google dot com
The nice thing is that desktop Chrome, Firefox, and Opera now support AVIF, at least for single images (not animations):

https://caniuse.com/avif

I assume Chrome for Android support is on the way, and since this work has involved many companies, I don't think we'll have to wait as long as we did for WebP for other browsers.

Talking to PHP core maintainers this weekend, I learned that PHP's GD is a fork of libgd. So we need to adapt the new gd_avif.c (https://github.com/libgd/libgd/blob/master/src/gd_avif.c).
 [2021-03-08 23:29 UTC] morss at google dot com
Tiny update: just learned that Chrome for Android does in fact support AVIF as of version 89. That brings the share of users whose browser supports AVIF up above 60%.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 21 07:03:33 2021 UTC