php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78826 Extension php_oci8_12c.dll is not a valid Win32 application
Submitted: 2019-11-17 14:52 UTC Modified: 2019-12-01 04:22 UTC
Votes:11
Avg. Score:4.4 ± 0.9
Reproduced:8 of 8 (100.0%)
Same Version:4 (50.0%)
Same OS:5 (62.5%)
From: bernat dot martin at outlook dot cz Assigned: cmb (profile)
Status: No Feedback Package: Dynamic loading
PHP Version: 7.3.11 OS: Windows Server 2019 x64
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2019-11-17 14:52 UTC] bernat dot martin at outlook dot cz
Description:
------------
The extension php_oci8_12c.dll, included in downloaded package from windows.php.net, cannot be loaded.

Test script:
---------------
php -v in command line

Expected result:
----------------
php -v
PHP 7.3.11 (cli) (built: Oct 22 2019 11:20:18) ( ZTS MSVC15 (Visual C++ 2017) x64 )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies

Actual result:
--------------
php -v
PHP Warning:  PHP Startup: Unable to load dynamic library 'oci8_12c' (tried: C:\PHP\v7.3.11\ext\oci8_12c (The specified module could not be found.), C:\PHP\v7.3.11\ext\php_oci8_12c.dll (%1 is not a valid Win32 application.)) in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library 'oci8_12c' (tried: C:\PHP\v7.3.11\ext\oci8_12c (The specified module could not be found.), C:\PHP\v7.3.11\ext\php_oci8_12c.dll (%1 is not a valid Win32 application.)) in Unknown on line 0
PHP 7.3.11 (cli) (built: Oct 22 2019 11:20:18) ( ZTS MSVC15 (Visual C++ 2017) x64 )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-17 15:17 UTC] cmb@php.net
-Status: Open +Status: Feedback -Package: PECL +Package: Dynamic loading -Assigned To: +Assigned To: cmb
 [2019-11-17 15:17 UTC] cmb@php.net
In the downloaded package, there is a file dumpbin.exe. You can
use it to check which DLLs are required by php_oci8_12c.dll, and
whether these are found on the system.  I assume that one or more
of these dependencies are not available.

See also the installation notes on
<https://www.php.net/manual/en/oci8.installation.php>.
 [2019-12-01 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Sep 22 16:03:37 2021 UTC