php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78773 XML extension doesn't compile in Mac OS
Submitted: 2019-11-02 19:38 UTC Modified: 2019-11-17 04:22 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: public at grik dot net Assigned: cmb (profile)
Status: No Feedback Package: XML related
PHP Version: 7.4.0RC5 OS: Mac OS 10.15.1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2019-11-02 19:38 UTC] public at grik dot net
Description:
------------
XSLT extension can't compile in Mac OS Catalina.

libxml2 is now located at
/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/libxml2/

$ xcrun --show-sdk-path
/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk

Test script:
---------------
./configure --with-xsl --without-iconv
make

Actual result:
--------------
/bin/sh /usr/local/src/php-7.4.0RC5/libtool --silent --preserve-dup-deps --mode=compile cc -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -Iext/libxml/ -I/usr/local/src/php-7.4.0RC5/ext/libxml/ -DPHP_ATOM_INC -I/usr/local/src/php-7.4.0RC5/include -I/usr/local/src/php-7.4.0RC5/main -I/usr/local/src/php-7.4.0RC5 -I/usr/local/src/php-7.4.0RC5/ext/date/lib -I/usr/include/libxml2 -I/usr/local/Cellar/openssl@1.1/1.1.1d/include -I/usr/local/Cellar/libpng/1.6.37/include/libpng16 -I/usr/local/Cellar/webp/1.0.3/include -I/usr/local/Cellar/jpeg/9c/include -I/usr/local/opt/libiconv/include -I/usr/local/Cellar/oniguruma/6.9.3/include -I/usr/local/src/php-7.4.0RC5/ext/mbstring/libmbfl -I/usr/local/src/php-7.4.0RC5/ext/mbstring/libmbfl/mbfl -I/usr/local/Cellar/libzip/1.5.2/include -I/usr/local/src/php-7.4.0RC5/TSRM -I/usr/local/src/php-7.4.0RC5/Zend  -no-cpp-precomp  -I/usr/local/opt/libiconv/include -g -fvisibility=hidden -O0 -Wall -Wno-strict-aliasing -DZEND_SIGNALS   -c /usr/local/src/php-7.4.0RC5/ext/libxml/libxml.c -o ext/libxml/libxml.lo
/usr/local/src/php-7.4.0RC5/ext/libxml/libxml.c:34:10: fatal error: 'libxml/parser.h' file not found
#include <libxml/parser.h>
         ^~~~~~~~~~~~~~~~~
1 error generated.
make: *** [ext/libxml/libxml.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-02 19:46 UTC] public at grik dot net
-Summary: XSLT extension doesn't compile in Mac OS +Summary: XML extension doesn't compile in Mac OS -Package: XSLT related +Package: XML related
 [2019-11-02 19:46 UTC] public at grik dot net
It's actually not just xslt, but an xml in general
 [2019-11-04 09:11 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2019-11-04 09:11 UTC] cmb@php.net
PHP 7.4 relies on pkg-config to find libxml2; is that properly
configured on your system?
 [2019-11-17 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2020-03-06 17:27 UTC] jesse dot greathouse at gmail dot com
It's fine if libxml2 is required for php 7.4. The problem is that this dependency issue doesn't appear until an error during compilation. There should be a check in the config to make sure it has all the necessary dependencies to perform the compile.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jul 02 07:01:25 2020 UTC