php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7875 ImageTTFText still mixes up x and y (in some cases?)
Submitted: 2000-11-18 16:50 UTC Modified: 2000-11-20 03:57 UTC
From: sander at steffann dot nl Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.3pl1 OS: Linux (RH6.2)
Private report: No CVE-ID: None
 [2000-11-18 16:50 UTC] sander at steffann dot nl
I noticed that there is still a problem with ImageTTFText. It mixes up x and y... I'm using GD 1.8.3 (with GIF support patched in, but it still uses pixels[y][x] like GD13+)
I tested this with Arvin's RPMS (http://rpms.arvin.dk/) and my own builds. Both have HAVE_LIBGD13 defined in php_config.h (several times in fact, but they all define it as 1) and I can't find any errors in the source myself... But still, it doesn't work right.....

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-18 19:04 UTC] markonen@php.net
I've never seen GD 1.8.3 with GIF support patched in. Is 
this software in public circulation? Could you send me 
a copy? In order to help you I need to take a look on 
how it behaves in ./configure.
 [2000-11-19 12:31 UTC] sander at steffann dot nl
The version I use is available at http://rpms.arvin.dk/gd-with_gif/ where you can find RPMS and sources/patches.
 [2000-11-20 03:57 UTC] steffann@php.net
Stupid... I had an old libgd.so somewhere on disk.... This wasn't a PHP bug, but my own mistake. After removing the old libgd.so everything works as expected. Sorry :)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Nov 19 20:01:37 2019 UTC