php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78742 each php sleep() creates new fpm-child-process
Submitted: 2019-10-23 15:10 UTC Modified: 2019-11-07 08:50 UTC
From: michael_bliem at gmx dot at Assigned:
Status: Not a bug Package: FPM related
PHP Version: 7.3.10 OS: debian buster VM
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michael_bliem at gmx dot at
New email:
PHP Version: OS:

 

 [2019-10-23 15:10 UTC] michael_bliem at gmx dot at
Description:
------------
standard installation of:
-debian buster
-php7.3-fpm
-apache2

each php-sleep seems to trigger creation of a new fpm-child-process.
this results in 503 errors when there are many requests if no more child-processes can be created


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-06 16:07 UTC] sjon@php.net
-Status: Open +Status: Feedback
 [2019-11-06 16:07 UTC] sjon@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

this is expected - a sleeping child cannot handle other requests so php-fpm will create a new child to handle new requests. Why did you think this is a bug?
 [2019-11-07 07:29 UTC] michael_bliem at gmx dot at
-Status: Feedback +Status: Open
 [2019-11-07 07:29 UTC] michael_bliem at gmx dot at
it does not scale! 

e.g.: if there is a sleep(1h) in a php-file and pm.max_children+1 clients call this php-file, the last one receives a 503-response! additionally for 1h the page will be offline (503) as all child-processes are idle for one hour...
 [2019-11-07 08:50 UTC] sjon@php.net
-Status: Open +Status: Not a bug
 [2019-11-07 08:50 UTC] sjon@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

you are correct but this is inherent to the design. You are welcome to build a sapi that does not have this problem.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Apr 13 03:01:23 2021 UTC