php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78687 --disable-all don't imply --disable-opcache-jit
Submitted: 2019-10-18 11:16 UTC Modified: 2019-10-18 12:09 UTC
From: bugreports@php.net Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: master-Git-2019-10-18 (Git) OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugreports@php.net
New email:
PHP Version: OS:

 

 [2019-10-18 11:16 UTC] bugreports@php.net
Description:
------------
while playing around with master and jit and turning out that it don't really work for my codebase at the moment (https://bugs.php.net/bug.php?id=78682) i also noticed that --disable-all don't imply --disable-opcache-jit

in other word --disable-all without --disable-opcache-jit and that two lines in the ini still triggers https://bugs.php.net/bug.php?id=78682 and --disable-all *really* means disable anthing which is not enbaled afterwards in configure

opcache.jit_buffer_size = 50000000 
opcache.jit = 1235


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-10-18 12:09 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2019-10-18 12:09 UTC] nikic@php.net
./configure --help

  --disable-all           Disable all extensions which are enabled by default

opcache-jit is not an extension, ergo it is not controlled by this flag. Same as SAPIs and other feature flags are not controlled by it, etc.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 19:01:28 2020 UTC