php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78623 Regression caused by "SP call yields additional empty result set"
Submitted: 2019-10-02 16:13 UTC Modified: 2019-10-03 11:03 UTC
From: attila at szeremi dot org Assigned: cmb (profile)
Status: Closed Package: PDO MySQL
PHP Version: 7.3.10 OS: Debian
Private report: No CVE-ID: None
 [2019-10-02 16:13 UTC] attila at szeremi dot org
Description:
------------
The fix to this bug in PHP 7.3.10 seems to have caused a regression: https://bugs.php.net/bug.php?id=41997

The error mentioned in that ticket seems to now be coming up, but triggered in a different way.

I made a repo where you can reproduce this with the help of Docker Compose: https://github.com/amcsi/php7.3.10-pdo-mysql-regression

If you downgrade the PHP version to 7.3.9, the problem goes away.

Test script:
---------------
https://github.com/amcsi/php7.3.10-pdo-mysql-regression/blob/master/example.php

Expected result:
----------------
array(2) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "1"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
}

Actual result:
--------------
array(3) {
  [0]=>
  string(5) "HY000"
  [1]=>
  int(2014)
  [2]=>
  string(269) "Cannot execute queries while other unbuffered queries are active.  Consider using PDOStatement::fetchAll().  Alternatively, if your code is only ever going to run against mysql, you may enable query buffering by setting the PDO::MYSQL_ATTR_USE_BUFFERED_QUERY attribute."
}

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-10-02 16:21 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2019-10-03 11:03 UTC] cmb@php.net
Thanks for reporting!

However, I cannot reproduce this (neither on Windows/mysqlnd/MySQL
5.6 nor on Travis[1]).  This may be a libmysql-client issue, or
may be related to some other database server (version).

If we can't make progress on this, I'll revert the fix for bug
#41997 within the next days, so 7.2.24RC1 and 7.3.11RC1 won't have
the regression.

[1] <https://travis-ci.org/cmb69/php-src/jobs/592985351#L3080>
 [2019-10-07 07:19 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=114c03b9a6122d85ec5ccaafc031ee47e7c26df8
Log: Fix #78623: Regression caused by &quot;SP call yields additional empty result set&quot;
 [2019-10-07 07:19 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 23:01:29 2019 UTC