php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78567 Error 500 for https://pecl.php.net/get/ssh2-1.2.tgz
Submitted: 2019-09-19 14:14 UTC Modified: 2019-09-22 16:06 UTC
From: arnaud dot goulpeau at guest-suite dot com Assigned: cmb (profile)
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2019-09-19 14:14 UTC] arnaud dot goulpeau at guest-suite dot com
Description:
------------
Could not download from "https://pecl.php.net/get/ssh2-1.2.tgz", cannot download "pecl/ssh2" (File https://pecl.php.net:443/get/ssh2-1.2.tgz not valid (received: HTTP/1.0 500 Internal Server Error

This URL is used automatically by our Scrutinizer, since 2019-09-18 minimum

Expected result:
----------------
I can download the file https://pecl.php.net/get/ssh2-1.2.tgz

Actual result:
--------------
Error 500

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-09-19 14:28 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2019-09-19 14:28 UTC] cmb@php.net
Duplicate of bug #78560.
 [2019-09-20 09:07 UTC] arnaud dot goulpeau at guest-suite dot com
This bug still exists :

https://pecl.php.net/package/ssh2, for the v1.2, links to https://pecl.php.net/get/ssh2-1.2.tgz which leads to a 500.

I know the https://pecl.php.net/get/ssh2 works, but since tools like Scrutinizer, composer and other automatic tools relies on what you put in this page (or another I admit I don't know), the url https://pecl.php.net/get/ssh2-1.2.tgz should work.

Please notice that the url https://pecl.php.net/get/ssh2-1.1.tgz works.

Many thanks for your help
 [2019-09-22 15:49 UTC] apostnikov at gmail dot com
The release still not downloadable by version number https://pecl.php.net/get/ssh2-1.2.tgz

It blocks adoption in Alpinelinux because packages build system require to point exact version in download URL
 [2019-09-22 16:06 UTC] cmb@php.net
-Block user comment: No +Block user comment: Yes
 [2019-09-22 16:06 UTC] cmb@php.net
This ticket has been closed as duplicate of another ticket[1];
please comment on that ticket.  Thanks.

[1] <https://bugs.php.net/78560>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Dec 12 16:01:24 2019 UTC