php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7853 session breaks Unicode font in Netscape
Submitted: 2000-11-16 13:52 UTC Modified: 2000-11-18 22:30 UTC
From: kpmm2000 at hotmail dot com Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.0.3pl1 OS: Solaris/Linux
Private report: No CVE-ID: None
 [2000-11-16 13:52 UTC] kpmm2000 at hotmail dot com
 Session BREAK!!

 session_start() and/or session.auto_start = 1; in
 php.ini will break HTML pages served with Unicode
 character set under Netscape:

 <meta http-equiv="Content-Type" content="text/html;
 charset=UTF-8">

 Under Netscape you will get blank BOXES on your HTML
 pages for a few seconds then automatically convert
 back to normal.  In some cases, the page stay with
 these codes in it.

 ---  If session_start or session.auto_start is taken out then the page shows up normal even with Unicode charset is set for the page.


I'm sure it has something to do with session function!!  


 This test was performed with PHP4.03 for Solaris/Linux and using Netscape4.6 on windows98

 PHP Developers, please fix this bug!

 Regards,

 Kenny

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-18 22:30 UTC] sniper@php.net
Reply by : Ignacio Vazquez-Abrams  <ignacio@openservices.net>:
-------------------------------------------------
This is a problem with Netscape, not PHP. The session stuff you mentioned
prevents Netscape from caching the page, which means it has to figure out
the charset stuff each time you go to the page. There's nothing that can
be done about it.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Nov 29 00:01:26 2023 UTC