php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78422 openssl_random_pseudo_bytes() -> Segmentation fault
Submitted: 2019-08-16 13:45 UTC Modified: 2019-08-16 14:10 UTC
From: thomas-php at digionline dot de Assigned:
Status: Duplicate Package: OpenSSL related
PHP Version: 7.4.0beta2 OS: Debian 10
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: thomas-php at digionline dot de
New email:
PHP Version: OS:

 

 [2019-08-16 13:45 UTC] thomas-php at digionline dot de
Description:
------------
openssl_random_pseudo_bytes() crashes PHP, when second parameter &$crypto_strong is given.

Test script:
---------------
<?
openssl_random_pseudo_bytes(4,$b);
?>


Expected result:
----------------
nothing.

Actual result:
--------------
Segmentation fault


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-08-16 14:06 UTC] requinix@php.net
-Status: Open +Status: Analyzed
 [2019-08-16 14:06 UTC] requinix@php.net
> Assertion `(zval_get_type(&(*(zstrong_result_returned))) == 10)' failed.
 [2019-08-16 14:10 UTC] nikic@php.net
-Status: Analyzed +Status: Duplicate
 [2019-08-16 14:10 UTC] nikic@php.net
Duplicate of bug #78391, which is fixed in beta3.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 19 08:04:05 2022 UTC