php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #78390 PHP 7.4 now supports string password hash algorithms
Submitted: 2019-08-09 12:24 UTC Modified: 2019-08-11 22:54 UTC
From: beebware at gmail dot com Assigned: salathe (profile)
Status: Verified Package: *Encryption and hash functions
PHP Version: 7.4.0 OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2019-08-09 12:24 UTC] beebware at gmail dot com
Description:
------------
---
From manual page: https://php.net/function.password-needs-rehash
And https://www.php.net/password_hash
---
Currently reads:

password_hash ( string $password , int $algo [, array $options ] ) : string
password_needs_rehash ( string $hash , int $algo [, array $options ] ) : bool

however, PHP 7.4 has changed the password algorithms to strings so it should be:

password_hash ( string $password , int|string $algo [, array $options ] ) : string
password_needs_rehash ( string $hash , int|string $algo [, array $options ] ) : bool

(or mixed)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-08-09 12:43 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-08-09 12:43 UTC] requinix@php.net
7.4 hasn't been released yet. The documentation covers stable releases, not the latest betas.
 [2019-08-09 13:06 UTC] girgias@php.net
-Summary: Documentation fault: PHP 7.4 now supports string password hash algorithms +Summary: PHP 7.4 now supports string password hash algorithms -Status: Not a bug +Status: Verified -Operating System: Windows +Operating System: -PHP Version: 7.4.0beta2 +PHP Version: 7.4.0 -Assigned To: +Assigned To: girgias
 [2019-08-09 13:06 UTC] girgias@php.net
@requinix this is not entirely true, we did already document changes which will happen in PHP 7.4 (see array_merge for example) as these changes may get forgotten when it releases.

Assigning to myself and will have a look next week.
 [2019-08-09 14:02 UTC] requinix@php.net
So are all 7.4 changes supposed to get documented as they're merged? Because there are all sorts of changes in the queue that should/would be documented but currently are not...
 [2019-08-11 22:25 UTC] girgias@php.net
-Assigned To: girgias +Assigned To: salathe
 [2019-08-11 22:25 UTC] girgias@php.net
Honestly no idea, I just know that some were documented while I was updating the French translation and I followed suit with some of them (e.g. the array_merge ones).

So maybe @salathe what is the official stance on this?
 [2019-08-11 22:54 UTC] salathe@php.net
PHP 7.4 is coming soon (we're at 7.4.0beta2 at the time of writing). It is fine having the new features/changes for 7.4 documented now. Just remember the changelog sections when documenting changes.

What we don't want to do is document something bleeding-edge only to have the feature/change changed in some way and have the documentation be incorrect. This is what can and does happen if we document changes as soon as they're committed to php-src.

A sensible line in the sand where that is much less likely to happen is feature freeze, which happens at beta1.  Once we've crossed that point we can, with high confidence, say that the change will be in the GA release. Consequently, it is fine to start documenting the changes fully expecting them to be in the GA release.
 [2019-08-27 18:56 UTC] joe at manvscode dot com
wrong
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 16 14:01:28 2019 UTC