php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78365 concatenation operation resolution in assignment
Submitted: 2019-08-02 09:56 UTC Modified: 2019-08-02 10:18 UTC
From: jcmargentina at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: *General Issues
PHP Version: 7.3.8 OS: Linux
Private report: No CVE-ID: None
 [2019-08-02 09:56 UTC] jcmargentina at gmail dot com
Description:
------------
The "assignment" operation (the = symbol) should be the last operation to be resolved. 

Test script:
---------------
<?php
$msg = "JOA" . isset($msg)?'OK':'X';
echo $msg;



Expected result:
----------------
JOAX

Actual result:
--------------
OK

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-08-02 10:18 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-08-02 10:18 UTC] cmb@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

<https://www.php.net/manual/en/language.operators.precedence.php>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Apr 21 21:01:24 2021 UTC