php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78213 Empty row pocket
Submitted: 2019-06-25 18:22 UTC Modified: 2019-08-07 06:31 UTC
From: v-altruo at microsoft dot com Assigned: cmb (profile)
Status: Closed Package: MySQLi related
PHP Version: 7.3.7RC3 OS: Windows
Private report: No CVE-ID: None
 [2019-06-25 18:22 UTC] v-altruo at microsoft dot com
Description:
------------
Test only fails for both x86 builds regardless of opcache on/off. Also fails for 7.4.0alpha1.

Failed Test File: ext\mysqli\tests\mysqli_store_result_copy.phpt 

Expected result:
----------------
array(2) {
  ["id"]=>
  string(1) "3"
  ["label"]=>
  string(1) "c"
}
id = 1, label = a
id = 2, label = b
id = 3, label = c
id = 4, label = d
id = 5, label = e
id = 6, label = f
No result: %d
Default
bool(false)
array(2) {
  [0]=>
  int(2)
  [1]=>
  int(1)
}
array(2) {
  [0]=>
  int(2)
  [1]=>
  int(1)
}
bool(false)
Copy
bool(false)
array(2) {
  [0]=>
  int(2)
  [1]=>
  int(1)
}
array(2) {
  [0]=>
  int(2)
  [1]=>
  int(1)
}
bool(false)
id = 6 label = f
id = 5 label = e
array(2) {
  ["id"]=>
  string(1) "6"
  ["label"]=>
  string(1) "f"
}
[020] [2014] %s
array(2) {
  ["id"]=>
  string(1) "6"
  ["label"]=>
  string(1) "f"
}
---
array(1) {
  [0]=>
  array(1) {
    [0]=>
    string(3) "100"
  }
}
---
array(2) {
  [0]=>
  array(2) {
    [0]=>
    string(1) "2"
    [1]=>
    string(1) "a"
  }
  [1]=>
  array(2) {
    [0]=>
    string(1) "3"
    [1]=>
    string(1) "b"
  }
}
done!

Actual result:
--------------
Warning: Empty row packet body in C:\...\php-test-pack-7.3.7RC3\ext\mysqli\tests\mysqli_store_result_copy.php on line 12

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-27 17:24 UTC] cmb@php.net
-Status: Open +Status: Verified -Package: Testing related +Package: MySQLi related
 [2019-06-27 17:24 UTC] cmb@php.net
I can confirm this.  However, I do not get any output from this
test on x86.  Anyhow, this looks like a real bug (not a testing
issue).
 [2019-07-22 18:10 UTC] v-altruo at microsoft dot com
Test also fails on PHP-7.3.8RC1 for only x86 builds regardless of opcache on/off. Result is same for TS/NTS builds.
 [2019-07-23 16:09 UTC] cmb@php.net
Thanks for the update!

Indeed, the child process is crashing due to some memory
mismanagement.  This may affect only x86 Windows builds.  It might
even be a ZendMM issue (not sure about that).
 [2019-07-31 16:10 UTC] cmb@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: cmb
 [2019-08-06 23:36 UTC] v-altruo at microsoft dot com
This test failed for PHP-7.3.8 for x86 only regardless of opcache on/off. 
It's the same output:

Warning: Empty row packet body in C:\...\php-test-pack-7.3-latest\ext\mysqli\tests\mysqli_store_result_copy.php on line 12
 [2019-08-07 06:31 UTC] cmb@php.net
The fix for this bug will be released with PHP 7.2.22, 7.3.9 and 7.4.0beta2.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 16:01:24 2019 UTC