php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78211 preg_match mismatch
Submitted: 2019-06-25 18:03 UTC Modified: 2019-06-25 18:14 UTC
From: v-altruo at microsoft dot com Assigned:
Status: Duplicate Package: Testing related
PHP Version: 7.3.7RC3 OS: Windows
Private report: No CVE-ID: None
 [2019-06-25 18:03 UTC] v-altruo at microsoft dot com
Description:
------------
Test fails only for TS builds regardless of opcache on/off. This test also fails for php-7.4.0alpha1.

Failed Test File: tests\basic\bug71273.phpt

Test script:
---------------
/* NOTE this file is required to be encoded in iso-8859-1 */

$cmd = getenv('TEST_PHP_EXECUTABLE') . " -n -d html_errors=on -d extension_dir=a/é/w -d extension=php_kartoffelbrei.dll -v 2>&1";
$out = shell_exec($cmd);

var_dump(preg_match(",.+a[\\/].+[\\/]w.php_kartoffelbrei.dll.+,s", $out));

Expected result:
----------------
int(1)
==DONE==

Actual result:
--------------
int(0)
==DONE==

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-25 18:14 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2019-06-25 18:14 UTC] requinix@php.net
Duplicate of bug #78118
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Aug 22 09:01:27 2019 UTC