php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78210 Invalid pointer address
Submitted: 2019-06-25 17:59 UTC Modified: 2020-03-09 13:50 UTC
From: v-altruo at microsoft dot com Assigned: cmb (profile)
Status: Closed Package: Streams related
PHP Version: 7.3 OS: Windows
Private report: No CVE-ID: None
 [2019-06-25 17:59 UTC] v-altruo at microsoft dot com
Description:
------------
Test fails across all builds regardless of opcache on/off. 

Failed Test File: ext\standard\tests\streams\bug74090.phpt

Expected result:
----------------
bool(true)
==DONE==

Actual result:
--------------
Warning: stream_socket_sendto(): The system detected an invalid pointer address in attempting to use a pointer argument in a call.

 in C:\...\php-test-pack-7.4.0alpha1\ext\standard\tests\streams\bug74090.php on line 17
bool(false)
==DONE==

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-26 21:53 UTC] cmb@php.net
-Status: Open +Status: Verified -Package: Testing related +Package: Streams related
 [2019-06-26 21:53 UTC] cmb@php.net
I can confirm this regression, which does not look like a testing
issue.
 [2019-06-28 08:09 UTC] cmb@php.net
Well, the test is failing for me since it has been changed with
commit 6bf1f43[1].

[1] <http://git.php.net/?p=php-src.git;a=commit;h=6bf1f434f089a00dccfd8a594e25191887c650d9>
 [2020-03-09 13:49 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2020-03-09 13:49 UTC] cmb@php.net
The following pull request has been associated:

Patch Name: Fix #78210: Invalid pointer address
On GitHub:  https://github.com/php/php-src/pull/5247
Patch:      https://github.com/php/php-src/pull/5247.patch
 [2020-03-09 13:50 UTC] cmb@php.net
-PHP Version: 7.4.0alpha1 +PHP Version: 7.3
 [2020-03-09 13:50 UTC] cmb@php.net
To clarify: this affects PHP 7.3 as well.
 [2020-03-11 10:33 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=53797c206a4304e0c322c39cb02abf891429367e
Log: Fix #78210: Invalid pointer address
 [2020-03-11 10:33 UTC] cmb@php.net
-Status: Verified +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon May 25 21:01:25 2020 UTC