|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7820 xmlFreeURI not found
Submitted: 2000-11-14 17:20 UTC Modified: 2000-11-16 03:37 UTC
From: dietricha at subpop dot com Assigned:
Status: Closed Package: DOM XML related
PHP Version: 4.0 Latest CVS (14/11/2000) OS: Debian Potato
Private report: No CVE-ID: None
 [2000-11-14 17:20 UTC] dietricha at subpop dot com
apache 1.3.14
php snapshot 11.13.00

configure error:
"checking for xmlFreeURI in
configure: error: DOM Module requires libxml >= 2.0"

configure command was "--with-dom=/usr/local/libxml2-2.2.8"

php was not ever able to find the libs if i installed them to /usr/lib. it also could not find them if i installed to /usr/local/lib, and specified that dir. the only way i got configure to see the libs was if i compiled from source, and didn't do "make install". then configure finally could see the libs, but gave me the xmlFreeURI error.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-14 17:29 UTC] dietricha at subpop dot com
configure command "--with-dom"
libxml2-2.2.7 in /usr/lib
libxml2-devel in /usr/lib

still got xmlFreeURI error.
 [2000-11-14 19:51 UTC]
Sounds to me like you already have Debian's libxml installed,
which is 1.8.3. Make sure that no other libxml exists on
your system.
 [2000-11-15 02:41 UTC] dietricha at subpop dot com
i already had apt-get removed libxml1

but to double-check, i did:
find / -name "libxml.*"
find / -name "libxml"
find / -name "tree.h"

and got only the current libxml2-2.2.7 and libxml-devel libs.

tried again compiling php4.03pl1 and the latest devel snapshot, but both with same error: no xmlFreeURI.
 [2000-11-15 10:31 UTC]
I have just checked every version of libxml from 2.2.2 (which
is what I use) to the latest CVS, and they all have xmlFreeURI
defined in /<includepath>/libxml/uri.h...

If you still have the debian libxml-dev package installed,
then you need to apt-get remove it, as it contains the
headers for 1.8.2.

If you don't, where did you get your "libxml-devel lib"?
 [2000-11-15 13:04 UTC] dietricha at subpop dot com
sorry i didn't specify. i am using libxml2-devel from the link at

just to double check, i grepped xmlFreeURI /usr/include/libxml/uri.h and found it.

also, i removed all my php amd libxml sources and packages and re-downloaded and went through my tests again last night. still got the xmlFreeURI error.

Php4.0.3pl1 configures past the --with-dom library check and the zlib check, and then chokes on the "xmlFreeURI" error, *without* having the libxml2-devel package installed.
When building php4-devel from 11.13.00, configure can't find the libs if i don't have libxml2-devel package installed. After i install libxml2-devel, *then* it gets the xmlFreeURI error.

 [2000-11-15 19:20 UTC] dietricha at subpop dot com

now attempting to build with a locally compiled libxml2-2.2.8, prefix=/usr/local

i get the same xmlFreeURI error, and configure keeps going.

i get the same xmlFreeURI error, and configure exits immediately.

i get the same xmlFreeURI error, and configure exits immediately.
i get the same xmlFreeURI error, and configure continues.

the behaviour is switched in the 2 versions(!?)
 [2000-11-15 22:56 UTC] dietricha at subpop dot com
found the problem:

i needed to have the zlib1g-dev package installed.

that allowed me to build php4-devel from 11.13 successfully.

thanks for your help!
 [2000-11-16 03:37 UTC]
Then we can close this.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Jun 07 15:03:42 2023 UTC