php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78166 php make fails compiling libxml.c
Submitted: 2019-06-14 18:49 UTC Modified: 2019-06-15 08:18 UTC
From: vosdeveloper1964 at gmail dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 7.3.6 OS: Solaris 11
Private report: No CVE-ID: None
 [2019-06-14 18:49 UTC] vosdeveloper1964 at gmail dot com
Description:
------------
PHP 7.3.6 make fails on Solaris 11 with compilation error for libxml.c

/bin/sh /usr/local/package/install_apache_php/php-7.3.6/libtool --silent --preserve-dup-deps --mode=compile /opt/csw/bin/gcc -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -Iext/libxml/ -I/usr/local/package/install_apache_php/php-7.3.6/ext/libxml/ -DPHP_ATOM_INC -I/usr/local/package/install_apache_php/php-7.3.6/include -I/usr/local/package/install_apache_php/php-7.3.6/main -I/usr/local/package/install_apache_php/php-7.3.6 -I/usr/local/package/install_apache_php/php-7.3.6/ext/date/lib -I/tmp/pkg/include/libxml2 -I/usr/local/include/net-snmp -I/usr/local/apache/ssl/include -I/usr/local/include -I/usr/local/instantclient_12_2/sdk/include -I/usr/local/package/install_apache_php/php-7.3.6/ext/sqlite3/libsqlite -I/usr/local/package/install_apache_php/php-7.3.6/TSRM -I/usr/local/package/install_apache_php/php-7.3.6/Zend  -D_POSIX_PTHREAD_SEMANTICS  -I/usr/local/include -std=gnu99 -fPIC -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fvisibility=hidden -DZEND_SIGNALS   -c /usr/local/package/install_apache_php/php-7.3.6/ext/libxml/libxml.c -o ext/libxml/libxml.lo
/usr/local/package/install_apache_php/php-7.3.6/ext/libxml/libxml.c:37:27: fatal error: libxml/parser.h: No such file or directory
compilation terminated.
make: *** [Makefile:603: ext/libxml/libxml.lo] Error 1

Test script:
---------------
./configure --prefix=/usr/local/apache/lib --exec-prefix=/usr/local/apache --with-apxs2=/usr/local/apache/bin/apxs --with-openssl=/usr/local/apache/ssl --with-curl=/usr/local --enable-sockets --enable-ftp --enable-soap --without-pear --with-oci8=instantclient,/usr/local/instantclient_12_2 --with-pcre-regex=/usr/local --enable-opcache=no
make
fails as indicated in description above



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-14 21:41 UTC] vosdeveloper1964 at gmail dot com
-Status: Open +Status: Closed
 [2019-06-14 21:41 UTC] vosdeveloper1964 at gmail dot com
the xml2-config file was corrupted. I reinstalled libxml2  and the php compile succeeded..
 [2019-06-15 08:18 UTC] cmb@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 08 11:01:23 2021 UTC