php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78133 Can't draw big ellipse
Submitted: 2019-06-08 17:19 UTC Modified: 2019-06-11 09:10 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jkarczm at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: GD related
PHP Version: 7.3.6 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jkarczm at gmail dot com
New email:
PHP Version: OS:

 

 [2019-06-08 17:19 UTC] jkarczm at gmail dot com
Description:
------------
imagefilledellipse draws a distorted shape when the size is big enough


Test script:
---------------
// Ellipse looks fine - size 500x500
$image = imagecreatetruecolor(500, 500);
$color = imagecolorallocate($image, 255, 0, 0);
imagefilledellipse($image, 250, 250, 500, 500, $color);
imagepng($image, 'D:/pass.png');
imagedestroy($image);

// Ellipse is distorted - size 5000x5000
$image = imagecreatetruecolor(5000, 5000);
$color = imagecolorallocate($image, 255, 0, 0);
imagefilledellipse($image, 2500, 2500, 5000, 5000, $color);
imagepng($image, 'D:/fail.png');
imagedestroy($image);


Expected result:
----------------
Ellipse should look like ellipse

Actual result:
--------------
Ellipse is distorted

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-10 21:03 UTC] cmb@php.net
This looks like a duplicate of bug #51498.
 [2019-06-11 09:10 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2019-06-11 09:10 UTC] cmb@php.net
This issue has also been reported upstream[1], and has been marked
as duplicate there, so I'm also marking as duplicate of bug #51498
here.

[1] <https://github.com/libgd/libgd/issues/502>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 07:01:23 2020 UTC