php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #781 Segfaults when both Sybase & MySQL compiled in & running NIS
Submitted: 1998-09-24 15:50 UTC Modified: 1998-10-04 14:09 UTC
From: jah at cultnet dot fi Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 3.0 Latest CVS OS: Linux 2.0.34 (glibc based)
Private report: No CVE-ID: None
 [1998-09-24 15:50 UTC] jah at cultnet dot fi
Shortest script to reproduce the problem: <? ?>

./configure --with-sybase=/opt/sybase --with-mysql --with-zlib --with-config-file-path=/etc/apache --enable-track-vars
--enable-magic-quotes --enable-debug

MySQL 3.21.33, SyBase what they just released for Linux.

Backtrace:

#0  0x4003de9e in db__init_charset ()
#1  0x4004064e in dbopen ()
#2  0x40212807 in _nss_db_getprotobynumber_r ()
#3  0x402129e1 in _nss_db_endservent ()
#4  0x40212c31 in _nss_db_getservbyname_r ()
#5  0x401e7436 in getservbyname_r ()
#6  0x401e72a2 in getservbyname ()
#7  0x8082ed9 in php3_minit_mysql (type=1, module_number=9)
    at functions/mysql.c:259
#8  0x8064cc0 in module_startup_modules () at internal_functions.c:483
#9  0x80599f5 in php3_module_startup () at main.c:1167
#10 0x805a5cb in main (argc=3, argv=0xbffffdd0) at main.c:1618

Both /lib/libnss_db-2.0.7.so and /opt/sybase/lib/libsybdb.so contain a function named dbopen(), so I already see what's happening. (This begins
to be not in any way related to PHP but someone else's fault...) Any ideas
of a workaround, or should this be put in FAQ under the section 'Thing's
you just can't do because some moron didn't think about naming
functions.'?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-10-04 14:09 UTC] zeev
Nothing can be done about it - the NIS implementation and
the Sybase libraries are simply incompatible.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun May 31 20:01:27 2020 UTC