php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7809 ld: 0711-317 ERROR: Undefined symbol: .alloca
Submitted: 2000-11-14 10:12 UTC Modified: 2002-03-22 00:00 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: ciukred at hotmail dot com Assigned:
Status: No Feedback Package: Installation problem
PHP Version: 4.1.1 OS: AIX 4.3.3
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2000-11-14 10:12 UTC] ciukred at hotmail dot com
After installation of php-4.0.3 I make this command:

./configure --prefix=/www --activate-module=src/modules/php4/libphp4.a

this is the last rows of error:

....

        cc  -DAIX=43 -DUSE_PTHREAD_SERIALIZED_ACCEPT -U__STR__ -DAIX_BIND_PROCES
SOR -qnogenpcomp -qnousepcomp -I/cercp/GIANLUCA/php-4.0.3 -I/cercp/GIANLUCA/php-
4.0.3/main -I/cercp/GIANLUCA/php-4.0.3/main -I/cercp/GIANLUCA/php-4.0.3/Zend -I/
cercp/GIANLUCA/php-4.0.3/Zend -I/cercp/GIANLUCA/php-4.0.3/TSRM -I/cercp/GIANLUCA
/php-4.0.3/TSRM -I/cercp/GIANLUCA/php-4.0.3 -DUSE_EXPAT -I./lib/expat-lite -DNO_
DL_NEEDED `./apaci` -lm -lpthread    -o httpd buildmark.o modules.o  modules/php
4/libphp4.a  modules/standard/libstandard.a  main/libmain.a  ./os/unix/libos.a
ap/libap.a  lib/expat-lite/libexpat.a  -Lmodules/php4 -L../modules/php4 -L../../
modules/php4 -lmodphp4   -ldl -lbind -lm -ldl -lcrypt
ld: 0711-317 ERROR: Undefined symbol: .alloca
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
make: 1254-004 The error code from the last command is 8.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-21 06:39 UTC] sniper@php.net
Could you try what is suggested in #4630 to see if it
can be used to fix this problem?

--Jani
 [2000-12-30 19:59 UTC] sniper@php.net
No feedback. And try php4.0.4 and reopen this bug report if this same thing
happens with it.

--Jani
 [2002-02-19 05:54 UTC] bahroni at telkom dot co dot id
I have an error message like this topic, but it was on AIX 4.3.1 and Oracle 8.1.7.
When I am installing Apache 1.3.23 and php-4.1.1 this error message appear :

ld: 0706-027 The -R /ora817/u01/app/oracle8i/product/817/lib flag is ignored.
ld: 0711-317 ERROR: Undefined symbol: .alloca
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
make: 1254-004 The error code from the last command is 8.
 
 
Stop.
make: 1254-004 The error code from the last command is 2.
 
 
Stop.
make: 1254-004 The error code from the last command is 2.
What I must do to solve this problem ?

Thank's.
 [2002-02-20 04:48 UTC] yohgaki@php.net
Status = Feedback

Could you try snapshot?
http://snaps.php.net/

 [2002-03-22 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC