php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #78058 sift -> shift
Submitted: 2019-05-23 14:56 UTC Modified: 2019-05-23 15:00 UTC
From: lexxur at gmail dot com Assigned:
Status: Not a bug Package: *Languages/Translation
PHP Version: 7.3.5 OS: all
Private report: No CVE-ID: None
 [2019-05-23 14:56 UTC] lexxur at gmail dot com
Description:
------------
---
From manual page: https://php.net/class.splpriorityqueue
---

Change `sift` to `shift` plz in "SplPriorityQueue::extract" description


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-05-23 15:00 UTC] daverandom@php.net
-Status: Open +Status: Not a bug
 [2019-05-23 15:00 UTC] daverandom@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

In the context of a heap, "sift" is the correct term, "shift" applies to stack/queue structure.

See https://en.wikipedia.org/wiki/Binary_heap
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 18 05:01:24 2021 UTC