php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #78013 SplDoublyLinkedList class constants definitions are missed
Submitted: 2019-05-15 08:30 UTC Modified: 2019-05-18 08:51 UTC
From: dn dot permyakov at gmail dot com Assigned: cmb (profile)
Status: Closed Package: SPL related
PHP Version: 7.1.29 OS: MacOS Mojave
Private report: No CVE-ID: None
 [2019-05-15 08:30 UTC] dn dot permyakov at gmail dot com
Description:
------------
SplDoublyLinkedList class page has a class definition and main constants like 

        const IT_MODE_LIFO = 2;
        const IT_MODE_FIFO = 0;
        const IT_MODE_DELETE = 1;
        const IT_MODE_KEEP = 0;

don't exist there

https://www.php.net/manual/en/class.spldoublylinkedlist.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-05-15 08:51 UTC] cmb@php.net
-Status: Open +Status: Verified -Package: *Programming Data Structures +Package: SPL related
 [2019-05-15 08:51 UTC] cmb@php.net
Confirmed.  These constants are listed and explained in the SplDoublyLinkedList::setIteratorMode() page, though.
 [2019-05-15 09:12 UTC] dn dot permyakov at gmail dot com
Yes they are, but i think the face of the class needed them to get faster understanding of main class features
 [2019-05-18 08:50 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=347439
Log: Fix #78013: SplDoublyLinkedList class constants definitions are missed
 [2019-05-18 08:51 UTC] cmb@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: cmb
 [2019-05-18 08:51 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2019-05-18 08:55 UTC] salathe@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=a2c9577295d898c73d618cfb88aaa391903eba7e
Log: Fix #78013: SplDoublyLinkedList class constants definitions are missed
 [2020-02-07 06:05 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=34f49a945c23f6013d346062306129d4619d9f95
Log: Fix #78013: SplDoublyLinkedList class constants definitions are missed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Sep 27 15:01:23 2020 UTC