php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77949 varnish 6 install error
Submitted: 2019-04-28 10:05 UTC Modified: 2019-04-28 14:08 UTC
From: 498936940 at qq dot com Assigned:
Status: Open Package: varnish (PECL)
PHP Version: 7.3.4 OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2019-04-28 10:05 UTC] 498936940 at qq dot com
Description:
------------
varnish6.1态varnish6.2
sudo pecl install varnish
checking for varnish files in default path... not found
configure: error: Please reinstall the varnish distribution
ERROR: `/tmp/pear/temp/varnish/configure --with-php-config=/usr/bin/php-config' failed



===

varnish 5.2
sudo pecl install varnish
is ok.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-04-28 14:08 UTC] cmb@php.net
It seems that varnishapi.h has been removed or renamed in varnish
6, but configure is still looking for this header[1], if
pkg-config is not available.  You likely can work around this by
properly configuring pkg-config.

[1] <http://svn.php.net/viewvc/pecl/varnish/trunk/config.m4?revision=344431&view=markup#l45>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 22 02:01:23 2019 UTC