php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77939 curl_close emits messages when it shouldn't
Submitted: 2019-04-24 21:24 UTC Modified: 2019-06-06 08:07 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: humbads at alum dot mit dot edu Assigned:
Status: Not a bug Package: cURL related
PHP Version: 7.2.16 OS: FreeBSD 11.2-RELEASE-p9
Private report: No CVE-ID: None
 [2019-04-24 21:24 UTC] humbads at alum dot mit dot edu
Description:
------------
With the sample script below,  curl_exec emits the message "HTTP Basic: Access denied." to stdout and curl_close emits the message "* Closing connection 0" to stderr.

These functions should not emit any messages.

I have:
cURL support => enabled
cURL Information => 7.64.1

I was able to reproduce the problem with all versions of PHP on my system, including PHP 5.6.39, 7.1.28, and 7.1.16.

Test script:
---------------
$ch = curl_init();
curl_setopt($ch, CURLOPT_URL, 'https://api.sellbrite.com/v1/inventory');
curl_setopt($ch, CURLINFO_HEADER_OUT, true);
print "Starting curl_exec\n";
@curl_exec($ch);
print "Starting curl_close\n";
@curl_close($ch);
print "curl_close finished\n";

Expected result:
----------------
Starting curl_exec
Starting curl_close
curl_close finished

Actual result:
--------------
Starting curl_exec
HTTP Basic: Access denied.
Starting curl_close
* Closing connection 0
curl_close finished

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-04-24 21:25 UTC] humbads at alum dot mit dot edu
-PHP Version: 7.2.17 +PHP Version: 7.2.16
 [2019-04-24 21:25 UTC] humbads at alum dot mit dot edu
I meant 7.2.16, not 7.1.16.
 [2019-05-13 10:49 UTC] divinity76 at gmail dot com
probably related to (but is not a duplicate of) bug #78007
 [2019-06-06 08:07 UTC] mike@php.net
-Status: Open +Status: Not a bug
 [2019-06-06 08:07 UTC] mike@php.net
Fixed in upstream libcurl 7.65, see https://github.com/curl/curl/commit/d934059afd8568201d0646d6bfd201f39b6bc412
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 09:01:27 2019 UTC