php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77824 REGRESSION Autocomplete suggestions for search have stopped working
Submitted: 2019-03-29 18:26 UTC Modified: 2019-03-29 18:35 UTC
From: teo8976 at gmail dot com Assigned:
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: teo8976 at gmail dot com
New email:
PHP Version: OS:

 

 [2019-03-29 18:26 UTC] teo8976 at gmail dot com
Description:
------------
Steps to reproduce:

1. go to https://www.php.net/
2. In the Search box on the top-right of the page, start typing the name of a function you know to exist, e.g. "microtime"

Expected result:
----------------
A list of autocomplete suggestions should appear below the box as a dropdown, based on functions  that actually exist (actually this should include other stuff besides functions, but that never worked; it used to work for functions though) whose name start with what you have typed

Actual result:
--------------
This used to work, but it no longer does.

Actually I see this error in the javascript console that pretty much looks like it could be the cause of this exact issue:

Access to XMLHttpRequest at 'https://php.net/js/search-index.php?lang=en' from origin 'https://www.php.net' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: Redirect is not allowed for a preflight request.

That's quite pathetic.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-29 18:35 UTC] requinix@php.net
-Status: Open +Status: Duplicate -Type: Documentation Problem +Type: Bug
 [2019-03-29 18:35 UTC] requinix@php.net
Duplicate of bug #77802
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 03 21:01:24 2020 UTC